How to pass $User from UA to UD?

Ok, so i’m runing the latest UA 1.5.0 night build. I’ve setup UA to run as a service under a service account. Did the setspn thing accordingly to the doc here: https://docs.ironmansoftware.com/config/security#windows-authentication-outside-of-iis
Created a new Dashboard via UA. Thing is: I can single sign on from the host, even from other computers on the lan, but i can’t sign on in the dashboard. I tried display the $User variable in the dashboard. I does not show. If I select authentication on the dashboard (via UA) the I can, again single sign on on UA (no problem here) but when i go to the Universal Dashboard i just created, it pops up the Login page. In the login page i cannot sign in with any user.
Made modification to web.config : forwardWindowsAuthToken=“true”
Made modification to app setting:

“Authentication” : {
“Windows”: {
“Enabled”: “true”
},
also in app setting i modified this:
“Kestrel”: {
“Endpoints”: {
“HTTP”: {
“Url”: “http://*:80”
}
}

Any suggestions why Windows Auth might not work on the Dashboard ?
Any workarrounds ?
Actually, i don’t even need auth, i just need the name of the user logged in on the computer that is using the Universal Dashboard.
Thanks.

I have the same issue.

This will be resolved in tonight’s 1.5 build.

thanks. i’ll try it now to see if the problem still occurs. will be back with feedback as results come in.

Hello again, tried the latest night build ( 330216916 Tue, 27 Oct 2020 00:33:25 GMT) still same issue.
Here is a demo (with dashboard authentication on):
udproblem

and here is a second demo without dashboard authentication:
udwithaoutauth

Am i missing something here ?

@PowerCode-K talked with Adam regarding this issue. with the last nightly build 1.5.0 the bug was resolved. it is working fine for me now. you should give it a try. if you still have problems, I might be able to guide you trough as i learned a lot from my experience setting UA and UD up.

Thanks for the heads up. Will go check it out. If I still have issues I will let you know.

@PowerCode-K 'm still having issues with Windows Authentication, specifically with IIS. IIS windows authentication appears to work ok, however, it asks me for credentials a second time.

I’m running nightly build 1.5.0 Build 332524324

I do also have IIS application crashes in the event log:

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: w3wp.exe
P2: 10.0.17763.1
P3: cfdb13d8
P4: KERNELBASE.dll
P5: 10.0.17763.1518
P6: ff301d3c
P7: e0434352
P8: 00000000000396c9
P9:
P10:

Attached files:
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER4124.tmp.WERInternalMetadata.xml

These files may be available here:
\?\C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_w3wp.exe_a8f7660cd44ba0ac261a6a57ef9c551ef2e3fb_98baeb8b_1b6a5bfd

Analysis symbol:
Rechecking for solution: 0
Report Id: c0bd56bd-65a0-4f3c-b105-c19d01af73b5
Report Status: 4196
Hashed bucket:
Cab Guid: 0

Do you see an event log entry referring to .NET Framework around that error you’ve posted? It should contain the actual reason for the crash.

There is also a App crashes for Universal.server.exe when I log in (10:48:10):

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: Universal.Server.exe
P2: 1.0.0.0
P3: 5dcec899
P4: KERNELBASE.dll
P5: 10.0.17763.1518
P6: ff301d3c
P7: e0434352
P8: 00000000000396c9
P9:
P10:

Attached files:
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER340F.tmp.WERInternalMetadata.xml

These files may be available here:
\?\C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_Universal.Server_294bad55d99f7254dc593ae225c9d0507f73dbd5_b4cd54dd_0e655e95

Analysis symbol:
Rechecking for solution: 0
Report Id: 31f1e41e-0995-4fa5-ad4a-1cebbf01716d
Report Status: 4196
Hashed bucket:
Cab Guid: 0

There is an event for .NET Runtime(10:48:19):

Category: Universal.Server.Services.DashboardManager
EventId: 0

Dashboard proxy for dashboard 1 not found.

Then a IIS AspNetCore Module V2 log (10:48:20):

Application ‘/LM/W3SVC/1/ROOT’ started process ‘2764’ successfully and process ‘2764’ is listening on port ‘31206’.

@crypticsh I know on the IIS and service account installation you have to force http1. Http 2 won’t pass windows authentication. When using chrome i had to change some setting to correctly pass authentication.

Thanks @PowerCode-K , do you remember what you did to force http1? I tried a few things from disabling http2 in the windows registry to using the --disable-http2 flag launching chrome with no luck (I rebooted etc. in between most testing). Are you running in IIS or as a service?

I guess the only difference between my scenario and the OP, is they are running as a service and I’m running it in IIS. I may end up trying that to see if that works.

Adam, if there is anything else you need from me or what me to try, let me know.

“Protocols”: “Http1”, Include in appsetting.json .

EX
{
“Kestrel”: {
“Endpoints”: {
“HTTPS”: {
“Protocols”: “Http1”,

https://docs.ironmansoftware.com/config/hosting