No components add button on my Dashboards menu. I trying to add a component that is in my Dashboard components

Can you please elaborate on what the problem you are having is? Is a bit unclear…

I have Universal dashboard on my IIS server for use in our intranet sites. So I am new to this. I download some components from the Marketplace. When I go to the Dashboard menu to add the components, there is only the add and import tab. I have the unlicensed version 1.3.1 for now.

Pretty sure you need to be on the Components screen and not the Dashboard screen.

From your original screenshot:

Its partly cut off, but that is the spot you need to be.

Add dashboard is to create a new dashboard and import dashboard is to point to an existing dashboard on your machine, they are not related to components

I have already downloaded the components see below on my Components screen.

Those components will be loaded to your dashboard when you launch it but based on your screen shots you don’t seem to have a dashboard yet.

Yes, the next step is to add the components to the Dashboard. Below is a screenshot from the online documentation.

To use these custom components you need to add them to your dashboard file by using import-module and the path to these components so when you do so will see these components when you launch your dashboard

Is there an advance mode for more option to directly add the components to the Dashboard per instructions, see link?

You need to first Add a new dashboard on the dashboards page. After you add the dashboard, click the Info button on the dashboard row in the dashboards table. This will take you to the dashboard info page and you will be able to add components on the components tab.

Thanks Adam, up and running with components installed from Marketplace.