PowerShell Universal VS Code Extension Configuration Question

Trying to get the extension working connecting to our production instance which runs on a server using IIS.

I’m able to connect, refresh, open log files, etc. But anytime i try to open or edit any of the ps1 scripts i revieve the following error…

Error running command powershell-universal.openConfigFile: ENOENT: no such file or directory, open ‘c:\PowerShellUniversalServer\UniversalAutomation\Repository.universal\roles.ps1’. This is likely caused by the extension that contributes powershell-universal.openConfigFile.

It’s looking to open the file from my local “c:” instead of the servers root. I’ve set the path to the remote server executable in the settings using the FQDN and path and also mapping the drive locally to my workstation and using “Q:\PowerShellUniversalServer”… but no matter what i change it to it still looks to local “C:” for the file. Is there some setting i’m missing???

I had this too. Let me double check my connection settings when I am back home and I will see if I can help.

1 Like

So in my extension settings I’ve got:

IIS Hosting

Does this help any?

Unfortunately it doesn’t… i have my settings like yours and still receive this when trying to edit a ps1 file from within vs code
Screenshot 2020-10-12 091437

Still trying to grab the file locally from what i can tell.

Currently, the extension is always looking locally. We’re looking at building a REST API to interact with the files that way so it would work remotely as well.

1 Like