UD 2.3 Released


#1

Universal Dashboard 2.3 has been released. Custom navigation, file uploads via New-UDInput, tabs and more!


#2

Thanks now my dark on dark dashboard can be slightly less dark.


#3

EDIT: Appears to be an issue with a single dashboard, others are fine. I’ll figure it out.

Starting a dashboard on 2.3 yields a server 500 error. 2.2.1 still works fine. Anyone else with this issue?

UDLogging throws:

09:43:36 [Info] Microsoft.AspNetCore.Hosting.Internal.WebHost Request starting HTTP/1.1 GET http://localhost:9999/
09:43:36 [Error] Microsoft.AspNetCore.Server.Kestrel Connection id “0HLKG6UNPKURB”, Request id “0HLKG6UNPKURB:00000001”: An unhandled exception was thrown by the application.

So far, restarting has not helped.


#4

Having the same issue with one of mine. If I pull out the Azure AD authentication stuff, it works.

Worked fine on 2.2.1.


#5

Just to chime in, I upgraded from 2.2 to 2.3 and broke my site. Static page with no authorization group works. Static page with authorization group not available despite group membership. Dynamic pages are blank.

Haven’t had time to troubleshoot yet.

Thanks,
Tim Curwick


#6

Are all of you guys using Azure AD? I guess the question is mostly for Tim…

Update - I can reproduce the issue with AzureAD and Dynamic Pages. I do not see an issue with static pages and authorization groups.

I opened two issues to track these bugs.


#7

Where do we find documentation for the new enhancements?

For example, the v2.3.1 release notes says that it now supports favicons. That’s good. How do I implement that? The release notes has a link to a GitHub issue that has no details.

Thanks,
Tim Curwick


#8

Adam,

I am using IIS and windows-integrated authentication to on-prem AD.

When I change $ClaimsPrinciple to $ClaimsPrincipal in my UDAuthorizationPolicy, I can now see the secured pages in the hamburger menu. (I thought you were going to leave that backwards compatible, but that’s okay; I don’t mind spelling it right.)

But the secured page does not work. I do have the navbar and footer bar, but there is nothing in between.

This page behaves normally:

New-UDPage `
    -Name 'Potato1' `
    -Content { New-UDHeading -Text 'Just testing' }

This page has no content (other than the NavBar):

New-UDPage `
    -Name 'Potato2' `
    -Content { New-UDHeading -Text 'Just testing' } `
    -AuthorizationPolicy 'AdminGroup'

Thanks,
Tim Curwick


#9

Adam,

A dynamic page is blank if the URL is set to a subfolder.
This works:
-URL ‘/Potato’

This results in a blank page:
-URL ‘/Potato/Banana’

Per Chrome developer tools, in the latter case, the contents of the main…bundle.js file and the vendor…bundle.js file are the same as the contents of the main html file, instead of the scripts they are supposed to be.

Thanks,
Tim Curwick


#10

To echo all the others, yes i am using AzureAD. If i comment out my loginPage (and thus authentication) the dashboard works fine.